anonymous@RULINUX.NET~# Last login: 2020-11-25 00:34:31
Регистрация Вход Новости | Разметка | Пользователи | Галерея | Форум | Статьи | Неподтвержденное | Трекер | Правила форума | F.A.Q. | Ссылки | Поиск
[#] [Добавить метку] [Редактировать]
Скрыть

Lost Labyrinth 3.5.3

Увидев, что есть RPM-"пакет" со свежей версией, решил обновиться.

"Скачал", удалив старую версию, попробовал "установить".

Последовало предупреждение о том, что требуется "libSDL_gfx.so.13" в "диалоговом" окне, в котором две кнопки - "Прервать" и "ОК", причём, по моему опыту, обе они приводят к одному и тому же результату - отмене "установки".

У меня Mandriva 2008.0, у кого более свежая версия, могли бы сообщить - эту ошибку исправили или это такое издевательство?

Подумал, что может требоваться просто ссылка на libSDL_gfx, создал "символьную" ссылку "libSDL_gfx.so.13", но это не помогло.

Потом посетил сайт SDL в поиске нужного, с него - сайт этой "библиотеки", там сборок не нашёл - может, просто плохо искал, но подумал (скорее "вспомнил"), что сборку, может быть, можно найти в "хранилище".

В качестве "хранилища" - mirror.yandex.

У 2008.1 нашёл, кажется, ту же версию,

у 2009.1 есть поновее, но решил посмотреть, что есть у 2010.1.

Там нашёл и "скачал"  http://mirror.yandex.ru/mandriva/official/2010.1/i586/media/main/release/libSDL_gfx13-2.0.20-2mdv2010.1.i586.rpm .

По названию можно было предполагать, что это то, что нужно.

Решил не удалять libSDL_gfx0 перед установкой - от неё зависели некоторые "пакеты", хотя, может быть, не такие и нужные.

Запустил "установку" нового "пакета".

Линия-показатель дошла до конца, но окно не закрылось. Может быть, это было связано с созданной "символьной ссылкой", а может и нет.

В итоге нажал "закрыть окно", через некоторое время показался диалог принудительного завершения, нажал "Завершить" (или как-то так), и окно "установки" довольно быстро исчезло.

В запущенном управлятеле "пакетов", после, кажется, обновления базы (которое запускается "вручную"), узрел, на своё удивление, два "пакета" libSDL_gfx: старый (libSDL_gfx0) и новый - libSDL_gfx13.

После этого попытался установить "пакет" с игрой, на что получил сообщение о том, что база RPM заблокирована.

После нескольких минут (и нескольких перезапусков X-сервера - хотя вряд ли это повлияло) удалось произвести "установку".

После этого отредактировал запускающий файл /usr/bin/laby , "закомментировав" строку "killall artsd" (вот зачем она там?), что делал и при другой версии игры.

Этот файл, кстати, не показывался (и не показывается) в KPackage, когда я открывал им "пакет" для просмотра списка "требований" ("библиотек" и т.п.).

А потом играл через "framebuffer" - так удобнее.

anonymous(*) (2010-07-24 20:37:00)

Opera/9.80 (X11; Linux i686; U; ru) Presto/2.2.15 Version/10.01

[Ответить на это сообщение]
[#] [Добавить метку] [Редактировать] Ответ на: Lost Labyrinth 3.5.3 от anonymous 2010-07-24 20:37:00
avatar
Скрыть

Re: Lost Labyrinth 3.5.3

> Линия-показатель дошла до конца, но окно не закрылось.
Все-таки глюкавая какая-то мандрива. Вродь и есть всё, но как-то кривенько порой работает.

> В итоге нажал "закрыть окно", через некоторое время показался диалог принудительного завершения, нажал "Завершить" (или как-то так), и окно "установки" довольно быстро исчезло.
Лучше таких вот выкрутасов не делать. С установщиком пакетов лучше не шутить. (Хотя что с ним делать если он завис?)

После созерцания того как urpmi вылетал с ошибкой сегментации в свежей мандриве 2010.0 я считаю, что сборщики там не слишком хорошо работают.

spaceivan(*)(2010-07-24 21:10:21)

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.6) Gecko/20100627 Gentoo Firefox/3.6.6
Этот тред читают 1 пользователь:
Анонимных: 1
Зарегистрированных: 0




(c) 2010-2020 LOR-NG Developers Group
Powered by TimeMachine

Valid HTML 4.01 Transitional Правильный CSS!