anonymous@RULINUX.NET~# Last login: 2022-08-13 00:55:29
Регистрация Вход Новости | Разметка | Пользователи | Галерея | Форум | Статьи | Неподтвержденное | Трекер | Правила форума | F.A.Q. | Ссылки | Поиск
[#] [Добавить метку] [Редактировать]
Скрыть

Python

При смене минорной версии интерпретатора, например с репозиторного 3.4 на левый 3.3, становится невозможен импорт репозиторных библиотек wxpython, pyside и т.д.

В чем проблема, как ее решать?

Poebunchik(*) (2014-06-26 16:27:42)

[Ответить на это сообщение]
[#] [Добавить метку] [Редактировать] Ответ на: Python от Poebunchik 2014-06-26 16:27:42
avatar
Скрыть

Re:Python

Полагаю в "левом 3.3", нет каких-то библиотек. Скин трасе ошибки, можно будет более точно что-то сказать.

Ax-Xa-Xa(*)(2014-06-26 16:45:46)
Отредактировано Ax-Xa-Xa по причине "не указана"
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36
[#] [Добавить метку] [Редактировать] Ответ на: Python от Poebunchik 2014-06-26 16:27:42
avatar
Скрыть

Re:Python

>В чем проблема, как ее решать?


В твоем левом питоне не установлены wxpython и pyside.

Решение: поставить эти либы. Олсо, man pip

anonymous(*)(2014-06-26 16:49:21)

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от anonymous 2014-06-26 16:49:21
avatar
Скрыть

Re:Python

> Олсо, man pip
Думаешь он не знает про пип? Скорее всего тет либ которые юзают wxpython и pyside. Хотя конечно пип должен бы был из переустановить.

Ax-Xa-Xa(*)(2014-06-26 16:50:54)
Отредактировано Ax-Xa-Xa по причине "не указана"
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36
[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от anonymous 2014-06-26 16:49:21
avatar
Скрыть

Re:Python

> В твоем левом питоне не установлены wxpython и pyside.
Я должен устанавливать все либы для каждой минорной версии интерпретатора? Даже для 3.3.1 и 3.3.2? Кошмар. Как же я буду расвивать и распространять крупные проекты на питоне. Мой IDE поддерживает только версии до 3.3, другие вообще не берет. Делаешь даунгрейд, теперь не работают библиотеки. Потом еще какая-то гадость определится.


# simple.py

import wx

app = wx.App()

frame = wx.Frame(None, -1, 'simple.py')
frame.Show()

app.MainLoop()
 


builtins.ImportError: No module named 'wx'
File "/home/def/Documents/Python/Pyside/hw1.py", line 3, in <module>
  import wx
 

Poebunchik(*)(2014-06-26 17:01:33)

[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от Poebunchik 2014-06-26 17:01:33
avatar
Скрыть

Re:Python

>Я должен устанавливать все либы для каждой минорной версии интерпретатора?


да

>Как же я буду расвивать и распространять крупные проекты на питоне.


с матами

>Мой IDE поддерживает только версии до 3.3, другие вообще не берет.


Что это за говноИДЕ? pycharm нормально работает с 3.4. Но тебе в любом случае придется курить virtualenv и pip для более-менее нормального деплоя.

anonymous(*)(2014-06-26 17:08:49)

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от anonymous 2014-06-26 17:08:49
avatar
Скрыть

Re:Python

> Что это за говноИДЕ?
Wing ide 4. Больше не развивается.

Poebunchik(*)(2014-06-26 17:12:48)

[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от Poebunchik 2014-06-26 17:12:48
avatar
anonymous(*)(2014-06-26 17:16:15)

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от Poebunchik 2014-06-26 17:01:33
avatar
Скрыть

Re:Python

pip wx

Покури про vitualenv, это решит все озвученные твой проблемы)))

Ax-Xa-Xa(*)(2014-06-26 17:18:04)

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36
[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от anonymous 2014-06-26 17:16:15
avatar
Скрыть

Re:Python

> https://wingware.com/downloads
Я знаю, но версия 4 больше не обновляется, а пятую покупать надо

Poebunchik(*)(2014-06-26 17:20:36)

[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от Poebunchik 2014-06-26 17:20:36
avatar
Скрыть

Re:Python

ну, тогда юзаю pycharm. Он имеет бесплатную версию. Да и платная стоит не так много

anonymous(*)(2014-06-26 17:34:06)

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
[#] [Добавить метку] [Редактировать] Ответ на: Re:Python от Poebunchik 2014-06-26 17:01:33Фильтры
avatar
  • матерные выражения
Скрыть

Re:Python

>Я должен устанавливать все либы для каждой минорной версии интерпретатора? Даже для 3.3.1 и 3.3.2?
дебиан при установке пакета сам создает ссылки в нужных местах для всех установленных версий питона.

алсо, нахуй тебе менять минорную версию?

virtualenv + pip + pip freeze > requirements.txt и pip install -r requirements.txt

>Как же я буду расвивать и распространять крупные проекты на питоне.
зачем тебе распространять чужие библиотеки?

если ты хочешь один бинарник то иди в py2exe, там и версия меняться не будет.

>Мой IDE поддерживает только версии до 3.3, другие вообще не берет.
лол, блядь, мышевозы плакают.

вим все умеет.

anonymous(*)(2014-06-26 18:57:19)

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Этот тред читают 1 пользователь:
Анонимных: 1
Зарегистрированных: 0




(c) 2010-2020 LOR-NG Developers Group
Powered by TimeMachine

Valid HTML 4.01 Transitional Правильный CSS!